Modding Union

[en] Edain Mod => [Edain] Support => Thema gestartet von: Lord of Mordor am 28. Mär 2015, 20:24

Titel: [en] Support Edain Demo 4.0
Beitrag von: Lord of Mordor am 28. Mär 2015, 20:24
If you have any trouble installing or playing the new version, please describe your problems as precisely as you can, and we'll try to help you get them solved :)


Frequent issues and questions

1. The game crashes when I click Skirmish, War of the Ring or Network in the main menu.

This problem occurs if you had last selected a custom hero or a faction that no longer exists in the Edain 4.0 Demo before you installed the demo. There are three possible ways to fix it:

1. Open the launcher, go into the "Options & Tools" menu and click "Fix Non-Starting Games".
2. Manually delete the folder "My The Lord of the Rings, The Rise of the Witch-king Files".
3. Disable the mod through the launcher and start the regular game. Delete all custom heroes. Then enter Skirmish and select Mordor as a faction. Enter the War of the Ring mode and select Mordor there as well. Quit the game and reactivate the mod.

2. I received a DirectX error when starting the game

This error is caused by the additional modification SweetFX, which we use to improve graphics. Uninstall Edain and install it again without checking "SweetFX" during setup.

3. My game does not start. The startup screen appears, but the game does not open.

This error can occur under the operating systems Windows Vista, Windows 7, Windows 8 and Windows 8.1 because they don't officially support the Battle for Middle-earth.  To fix this, open the launcher, go into the "Options & Tools" menu and click "Fix Non-Starting Games". Error messages like "Insert the correct CD / DVD ROM" will NOT be fixed this way.

4. I have a lot of "Missing" errors instead of actual text.

You most likely do not have the base game installed in German or English. Edain text will only be displayed 100% correctly if your base game is installed in one of these two languages. Uninstall the mod and the game, then reinstall it in German or English.

5. I created an custom hero but I can't select it for skirmish.

To choose a custom hero, first click on his greyed-out name in the list, then press the first button of his name on your keyboard. This way, every hero can be chosen for every faction. If you hover your mouse cursor over the box where you select your own hero, a popup will appear that also contains these instructions.

6. The game crashes after roughly 15 minutes.

In case of unexplained crashes, first try uninstalling both the mod and the base game and reinstalling from scratch. If that doesn't help, post your problem in our Support Forums. But first, ensure that you are not running a crack or no-CD-patch. These are not compatible with the Edain Mod and should not be discussed in our forums due to their illegal nature.

7. Units in the game are pink or invisible.

Most likely this means you have a corrupted asset.dat. In many cases, this problem can be solved by uninstalling the mod, then reinstalling it. If you still have the same problem, try redownloading the entire mod and installing it from the redownloaded files. If the problem persists, please contact us on Moddb or in the Modding Union forums.

8. I can't play as Arnor.

Arnor is not a full faction of its own. Instead, it replaces Gondor on maps that have a thematic connection the war between Angmar and Arnor. If you select Gondor an any of these maps, you will control Arnor instead:

- Angmar
- Arnor
- Cardolan
- Carn Dûm
- Fornost
- Fortress von Amon Sûl
- Forodwaith
- Forochel
- Mitheitelspring
- Mountains of Angmar
- River Luhn
- Mountain Gram
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Lord of Mordor am 28. Mär 2015, 21:14
Updated with the most frequent issues and their solutions.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 28. Mär 2015, 22:43
Updated with 2 more solutions.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Elite KryPtik am 29. Mär 2015, 07:03
Hello Edain team xD I have just downloaded your mod, but I cannot figure out where the installer is. It comes in a zip file of course, and once I unzip it all I can do is run the launcher, which doesn't install the game. Clicking play Edain mod of course comes up with an error because the mod hasn't been installed yet. I looked through every single folder and I cannot find the installer. I also tried running the program without unzipping it and I can't, as it has no extension while it is zipped, so windows cannot open it. So I'm stuck on how to get this thing installed, and I really want to play it. I have screenshots of everything relevant I could think of, but your site does not allow me to attach png files so I can't show them to you :( I hope this isn't a stupid question lol  :D
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Lord of Mordor am 29. Mär 2015, 09:32
Hey, where did you get that download? It shouldn't be a .zip file, it should be a simple .exe file. Just run that, and it will install Edain automatically for you :)

You can get it here at Moddb (http://www.moddb.com/mods/edain-mod/downloads/edain-40-demo-dontt-auth).
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Elite KryPtik am 29. Mär 2015, 12:13
I downloaded it from moodb initially, and it came in a zip file. I'll try following your link though  :)

Just fixed it, I had to manually add the .exe extension to it, after downloading the file it didn't have the extension. Same thing happened when I started downloading from your link, you might want to look into this. If anybody has the same problem by some odd chance tell them to rename it and add the extension manually. Maybe my computer is just a unique fucked up case  :D Thanks for your help!
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 29. Mär 2015, 12:16
Great, have fun with it!  xD
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: DarkStalker am 30. Mär 2015, 17:12
hey i have a problem. when i start the Edain Mod, the news doesn't appear, and when i try to play it, the RotWK has benn minimised. What is the problem?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Dark_Númenor am 30. Mär 2015, 17:16
What do you mean with "the news"?
If it doesn't start i would recommend you to deinstall the Edain Mod via the included uninstaller (You'll find it in your RotWk folder) and reinstall it :)

Sincerely Dark Númenor
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: DarkStalker am 30. Mär 2015, 17:31
I mean with the news are showing just text and is says: Label,label,Text.
The mod couldn't uninstall the files from the folder, and also the uninstaller stay in the folder
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 30. Mär 2015, 17:33
Those "labels" show up when your launcher could not yet download any news.
Which files couldn't be uninstalled? And jeah, the uninstaller stays, the uninstaller can't delete itself in the system we are using.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: DarkStalker am 30. Mär 2015, 17:35
I'll try it what Black Numenór said.
_____________________

Found the solution. My notebook can't play the game in 720p as 1280*720, i don't know why, but in the other resolution starts...I could play 720p yesterday. I think nothing happened after that. :D

________________________

nothing happened :/ always minimizes it :/
EDIT: I have to wait when it's been minized :D run perfectly, but i don't know why does the games have to minimize it...
REEDIT: nothing...it doesn't work anymore :/



Edit by Turin: Merged the posts.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 30. Mär 2015, 17:55
Maybe your monitor does not fit with this resolution since it has lower dimensions in one of those two.
So you can play now?

By the way: Please use the edit function instead of double posting. Edited Posts will also listed as new ones for users so no need to double post. ;)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: DarkStalker am 30. Mär 2015, 18:18
Yeah it works now. And I keep the editing thing in my mind :P
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: iofthesquid am 31. Mär 2015, 01:34
Hi,
I have tried using the option to fix startup but I'm still getting a crash at startup.  Also, I didn't have this problem with 3.8.

I have tried to attach the error message, which I could only screenshot, but you have to rename the file to .jpg instead of .txt.  Any ideas? 

something about expected signed integer value with command points in the gamedata.ini file

Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: iofthesquid am 31. Mär 2015, 01:41
it definitely is something to do with the game.dat

I'm running Windows 8.1 and the old mod worked fine! 
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 31. Mär 2015, 09:29
Delete previously installed submods, if you had the hero submod installed: search for updates in the Edain launcher and install it. The update will disable the submod.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Happytreehugger am 1. Apr 2015, 04:36
I successfully installed the Edain 4.0 mod on the Mod DB website.  The audio seems to be all in English, but all the text is in German.  How exactly do you translate this?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: hoho96 am 1. Apr 2015, 23:53
Change the language from the Launcher.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: KelnorTheMeek am 2. Apr 2015, 02:37
Hello,
I downloaded the edain 4.0 demo, but it says it is missing the options.ini file, Command Point Start error, and also says the MAP MP Bree path is invalid. I uninstalled the demo and reinstalled vs 3.8.1 and now that one won't work either. My buddy and I have the same PC and he was able to download and play with no problem.

Please help...
I'll try and give more info by Friday as I won't have access to the internet until then.

Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 2. Apr 2015, 10:27
Did you have any other mods installed? Did you have submods for Edain 3.8.1 installed?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: iofthesquid am 2. Apr 2015, 23:49
Turin, I ended up getting it working!!  I didn't have any submods and still cannot explain why it didn't work in the first place.  Once again I am running on Windows 8, 64-bit. I still don't know what the issue was, but here's what I did:

-Uninstalled and deleted everything.
-reinstalled both bfme2 and rotwk.
-manually added in a few missing files out of the winrar files on my ROTWK DVD because the installer is sketchy as fuck and missed things sometimes.
-updated both games, installed the "lotr update and fix.exe" to make bfme2 run.
-applied the "no CD fix" to Rotwk with daemon tools to avoid the no-cd error (and purple screen errors, etc).
-applied  your old "bfme_startup_fixxer_.exe" to fix the ini error.

AND NOW EVERYTHING WORKS AGAIN  ;)

PS all of those files I mentioned can be found on Google in places like gamecopyworld and moddb.  good luck to anybody with similar problems!! 
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: bookworm1138 am 3. Apr 2015, 07:32
Trying to download the 4.01 update, but after the download finishes, i receive an error message (i cannot upload an image of it):

"edainswitcherinstaller.e xe has stopped working. A problem caused the program to stop working correctly."

...and I cannot complete the update.  :(
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 3. Apr 2015, 09:07
Do you receive an additional message with a message that says an error log was created?
Did you try it again?
Edit: OK, did not read well..
Download the launcher update here: http://modding-union.com/cf/mods/edain2/mod/dl51.php?URL=http://modding-union.com/updates/edain2/switcher/edainswitcherinstaller.exe
Then search for updates again.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Grommosh am 3. Apr 2015, 09:51
I need some help with the 4.0. I play war of the ring, And I attack Rudahur and enter the map in "Real Time" and I can't build a camp only settlements and outposts. but if its a map like the shire I lose automatically after 5-10 seconds with out building anything.

can i get some help please
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: numan1111 am 4. Apr 2015, 01:39
I cant update the mod.It stopped downloading at %.. when I press the update button in launcher.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: bookworm1138 am 4. Apr 2015, 05:32
Do you receive an additional message with a message that says an error log was created?
Did you try it again?
Edit: OK, did not read well..
Download the launcher update here: http://modding-union.com/cf/mods/edain2/mod/dl51.php?URL=http://modding-union.com/updates/edain2/switcher/edainswitcherinstaller.exe
Then search for updates again.

there was no error log created, and i already tried to download the launcher update (once before, and again after receiving this message): nothing
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 4. Apr 2015, 10:36
I cant update the mod.It stopped downloading at %.. when I press the update button in launcher.
You need 7gb on your participation. Check this.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 4. Apr 2015, 11:25
Your connection timed out. Next version of the launcher will abort the downloading in this case. Close the launcher via task Manager and try again.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 4. Apr 2015, 12:57
You have installed some Submods. Uninstall them, uninstall Edain and reinstall Edain (dont forget the patch).
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: bookworm1138 am 4. Apr 2015, 16:53
You have installed some Submods. Uninstall them, uninstall Edain and reinstall Edain (dont forget the patch).

if this was in response to my issue, let me state that i have no other mods (main or "sub") installed. i got BfME2 and RotWK installed from their CDs without any other addition, then installed Edain and up until i tried to update (or run edainswitcherinstaller.e xe) everything worked fine
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 4. Apr 2015, 17:38
http://modding-union.com/updates/edain2/switcher/edainlauncher1.0.0.2.exe
Try this download.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Crimson King am 5. Apr 2015, 03:23
Hello Edain team, first this is my first post here, so let me thank you for the great gaming experience that playing Edain mod is, you guys are the real mvp :)

I have encountered a problem though, which does not seem to be a bug, I'm not sure what this is actually, but I simply cannot upgrade any building that is not a resource source. Does not matter with which faction, against which one or what map I'm in. I have no option when i click any non-resource building in order to upgrade it like there used to be in RotWk (the 4.0 is the only mod i've played so I don't know how it was in previous versions). This leaves me unable to recruit certain units or purchase some upgrades. Any idea what might be causing this and how to fix it?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: bookworm1138 am 5. Apr 2015, 05:43
http://modding-union.com/updates/edain2/switcher/edainlauncher1.0.0.2.exe
Try this download.

no difference
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Chiska am 5. Apr 2015, 10:13
Hi Edain Team. Wow Edain 4.0 demo has been simply amazing! This is by far the most addctive and awesome GAME I have ever played. But I have this one issue that frustrates me; Mordor's defensive towers can't get fire arrows. I have tried using the Influence of Sauron but I can't use it on any of the smaller battle towers. Perhaps I need to use it on the larger battle tower that is built on one of the build plots, but will that upgrade ALL my battle towers with fire arrows, or just the bigger ones built inside? I think it's an unfair disadvantage to Mordor if their small battle towers can't receive fire upgrades (I mean Isengard's smaller towers can receive upgrades!). So please if the little ones can't get upgrades would you consider giving it to them? And if they can please instruct me on how to do it. Thanks
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: TiberiusOgden am 5. Apr 2015, 10:33
Chiska,
glad to see you here.  :)

Mordor's defensive towers can't get fire arrows. I have tried using the Influence of Sauron but I can't use it on any of the smaller battle towers. Perhaps I need to use it on the larger battle tower that is built on one of the build plots

Yes,
you have to use Sauron influence on the normal battle tower (larger build plots) and then all battle towers (even small towers) have fire arrows.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Chiska am 5. Apr 2015, 11:49
Tanks Tiberius, it gonna take some money now and an extra build plot...then again Mordor always was a bit overpowered so a little bit of difficulty here and there wont hurt ;)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: TiberiusOgden am 5. Apr 2015, 12:07
it gonna take some money now and an extra build plot...then again Mordor always was a bit overpowered so a little bit of difficulty here and there wont hurt ;)

Exactly my thoughts.  ;)
Either way Mordor has some restrictions.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: DarkStalker am 6. Apr 2015, 22:54
Hi everybody. I'm having an issue. I couldn't upgrade the edain, but on my desktop PC could, on laptop say: Couldn't connect to the server. can someone help me? i see the switcher, but i'm reinstalling RotWK and the Edain mod.
EDIT: When I installed from the Switcher, i saw that the installer skipped the news.ini file.
Can you help me in that too?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: bookworm1138 am 7. Apr 2015, 16:54
i know i've already posted several times, but this is fast becoming a serious problem.

upon attempting to update, the launcher stops working, giving me a vague message: "edainlauncher1.0.0.2.exe has stopped working. A problem caused the program to stop working correctly." i have ran the compatibility troubleshooting program on the launcher, this has not resolved the issue. i have updated BfME2 and RotWK, thinking that might have been a cause of the issue: i still get the same message. several replies i have received to this problem have just sent me an alternate link to the same launcher file which, once again, stops working.  :-|

i have tried everything i know short of taking yet another day to uninstall and reinstall ALL the programs associated, and nothing has worked. at this rate, the Edain 4.0 mod, no matter how well done, is useless because it cannot be updated beyond the demo version  :(
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 7. Apr 2015, 17:05
You know, the problem is that you are the only person with this problem. So there can not be a general trouble shooting...
I have no idea why the setup is crashing on your computer, nur is definitly connected to your computer and your configuration of it. I will send you a file and instructions  for it, with this file you will be updating the launcher manually.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: DarkStalker am 7. Apr 2015, 18:12
I had the problem, I could update the launcher and the game as well. The proxy doesn't allow to upgrade anything, so i had to use my mobil network, and it works fine :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: j0rizz am 7. Apr 2015, 21:12
My game random crashes after playing about 20 min. I made a screenshot of the error I get:

(http://i.imgur.com/FLq2vdr.jpg)

Anyone know how to fix this?

BTW: awesome mod, this is how the game should have been from the beginning.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 7. Apr 2015, 21:16
Did you install Patch 4.01? This error is most likely caused by sweetfx, which is deleted with the patch.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: j0rizz am 7. Apr 2015, 21:27
I installed the patch the same day it was released. I did not install the SweetFx mod.

When I downloaded the mod I updated BfmE to 1.06. I did a clean install of RotWK and updated it to 2.01. Then I installed the mod and later on I patched it to 4.01. Any more suggestions?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: numan1111 am 12. Apr 2015, 22:42
I tried to update edain mod to 4.01 with launcher like 100 times but I cant update it.Always it stopped connection at %.. This is really ridiculous guys.I cant play multiplayer.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 13. Apr 2015, 10:56
Checked this?
Your connection timed out. Next version of the launcher will abort the downloading in this case. Close the launcher via task Manager and try again.

I cant update the mod.It stopped downloading at %.. when I press the update button in launcher.
You need 7gb on your participation. Check this.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Grommosh am 13. Apr 2015, 20:51
ok i have unistalled both Edain and RotWK and I keep getting the following

"Lotr RotWK has top working"...anyone got a clue on how to fix this
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: osoriocoronado am 14. Apr 2015, 00:49
Hey, I have an issue with invaild sound. Please, how do I fix it?
It says
Invalid Sound 'SnowStereoLoop'
And a lot of errors below.

Also, does ROTWK has to be patched to play this modd? I really want to play it and have tried uninstalling the unofficial ROTWK patch, re-installing the game and the modd and nothing works, it is the same sound error that causes the game to crash before it even starts, as soon as I hit play.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Romanik am 19. Apr 2015, 23:47
Hi Edain Team,
I have a such of trouble with factions. Maybe it's a stupid questions but I really can't explain how it can be. I already did all the updates, but I have only 4 factions, what about elves? I saw a lot of gameplay videos with elves but in 4.01 there aren't any elves. How can I get them? Thanx a lot!  :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Elendils Cousin 3. Grades am 20. Apr 2015, 00:05
That is completely intentional. You are playing a demo, which only includes the four factions that were ready to be released. The other factions will be added later.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: sodoras am 29. Apr 2015, 05:04
Hi  I'm NEW to the edain mod and i try to install it with the help of a friend, you might slightly know him, names EliteKryptik he is a beta tester.
 He helped me a lot in order to get the game running but we encountered a problem. We  uninstall the games (i have all 3 of them on disc) and also used regedit to clean all files of the games from the registry.
We then reinstalled everything from scratch and downloaded fresh patches etc
bfme 2 patch is on 1.06 and the rotwk is on the 2.01
We try to run it and still the same error. After that we uninstalled it all again and
we installed it without me changing the install directory ( i formerly was installing to my own path) we installed again from scratch did all the patches and switchers and also i install the First BFME and patched it. The patches are still in 1.06 and 2.01 and the First is on the 1.03. We make all the updates for the edain and we ran everything as administrator each time and the game still crashes , we also try using the fix non starting games tool and nothing. Here is the error message.

Invalid Sound WOTR_MusicRohanMS

Error parsing field 'Music' in block 'LivingWorldPlayerTemplat e' in file 'Data\INI\LivingWorldPlayers.ini', line 59.


Error parsin INI block '    Music' in file
'Data\INI\LivingWorldPlayers.ini',
7 addresses:
(unknown)(0): game.dat+239838 Debug::PostStaticInit+3390
(unknown)(0): game.dat+2346667
StringBase<char> + 262887
(unknown)(0): game.dat+6541831 Xfer::operator==+119943
(unknown)(0): kernel32.dll+78698 BaseThreadInitThunk+18
(unknown)(0): ntdll.dll+234162 RtlInitializeExceptionCh ain+99
(unknown)(0): ntdll.dll+234162 RtlInitializeExceptionCh ain+54

I hope you can help me, thanks for your time!  :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Elite KryPtik am 29. Apr 2015, 05:08
Hey guys, I just want to verify that sodoras is telling the truth, we did everything he posted. Tis error is still coming up, to my eternal annoyance  :-| We were connected the entire time on TeamViewer and I tried everything I could to get it working, but no dice. Hope you guys on the team are familiar with this error, its beyond me  :(
Best of luck, thanks for any help!  ;)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Elite KryPtik am 30. Apr 2015, 01:29
Well that's just fucking wonderful! It seems that whatever the problem is that sodoras is having is also now happening on my computer. Here is a picture of the error message. I hope somebody knows how to fix this  :(

(http://i.imgur.com/ZDN5bTM.png?1)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: FG15 am 30. Apr 2015, 07:31
Did you recently install any other mods or submods? I just checked it and the missing sound is part of the data\ini\music.ini, so obviously something with a higher priority overwrites this file.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: sodoras am 30. Apr 2015, 18:23
no, no other mods or submods only original games with the patch switchers, nothing else.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 30. Apr 2015, 19:00
Well the patch switcher is integrating patches as mods so it wont work with Edain. You need to install only a raw Rise of the Witchking with 2.01 official patch and Edain, nothing else.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Elite KryPtik am 30. Apr 2015, 19:04
I find that strange, because my original install worked fine with 2.02 installed. Maybe something in the update changed this for a fresh install? After I got done helping sodoras out I had a different error come up, and so I had to do a uninstall reinstall, no big deal I figured. But then once I finished, I started getting the same error. I'll try installing without 2.02 and let you know. But my original install had 2.02 installed, so something has changed.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Elite KryPtik am 30. Apr 2015, 19:24
No luck, I just tried installing Edain without 2.02 installed on my system, and I'm still getting the same error. I'm a lot more technically capable than some people, so if you want to tell me anything that's left behind after uninstalling Edain ROTWK and BFME2, including in the registry, I'm willing to do another full uninstall and cleanup for both me and sodoras. I was pretty thorough the first couple of times, but I don't know everything about the registry. If anybody has the time, you can also come onto my computer remotely via teamviewer, and try to figure this out that way.

A third idea would be for you to give me a jury rigged BIG file and I could try just pasting into into our folders, can you make something code-wise which gives that music file higher priority? I don't think either of us are looking to play online with anybody but each-other for now, so this would at least get the game running again if you can do it.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 30. Apr 2015, 20:44
Well, there are propably left overs of 2.02 thats why the game is crashing. Easiest thing is check your Rise of the Witchking folder und see if there are any .big of 2.02. I have no idea how they are called, so you need to find out yourself. But you could also post a screenshot of the folder, because I know which files are Edain and RotWk files so we could sort that out.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Elite KryPtik am 30. Apr 2015, 23:08
Well I'm really doubtful that this is the source of the issue, but here you go anyways. I uninstalled Edain and 2.02, here's the folder afterwards.

(http://i.imgur.com/MO2ZAvE.png?1)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 30. Apr 2015, 23:15
First of: Were are you Edain files? Did you uninstall it?
Second: __lobbymusicminimod is propably the cause the crash.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Elite KryPtik am 30. Apr 2015, 23:20
Yeah I had uninstalled Edain as well, I just uninstalled ROTWK and deleted the folder, did a new install from scratch without 2.02 and im now installing edain. Once I get it updated ill try running it and see what happens, ill let you know when its done in a little bit.

EDIT: Damn me for a fool, you're right! That's REALLY weird, especially considering it worked fine for me with 2.02 at first. I'm gonna do some fiddling and try to get it working with 2.02 on my PC, because I only play 2.02 when I do play vanilla ROTWK. Maybe now that we have identified the source of the issue you guys can try and do something to make it compatible? Thanks for the help Turin, I'll get sodoras fixed up next time I talk to him.  :)

EDIT 2: Got it working with 2.02, just had to delete 3 files associated with the lobby music mod that comes with 2.02. And of course you have to disable 2.02 while running the mod.

There removed the triple post, my bad.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 1. Mai 2015, 00:16
Please use the edit function of our forum, there is no need for triple or double posts. ;)

We are not planing to add official support for 2.02 or other fan made patches, we are going to stick with 2.01 since it is the official one.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: MacGyver27 am 31. Mai 2015, 20:18
GAME CRASH:

BFME2 - patch 1.06
WitchKing - patch 2.01

I always encounter this game crash. I have tried reinstalling couple times and still same crash at the exact moment.

While playing skirmish I will receive a game pop up saying "Troops from our fiefdoms have reached the battlefield!" and immediately game crashes with message:

"\game.dat    This application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information."

(http://oi58.tinypic.com/1zdrdrc.jpg)

Please fix let me know if it is a bug and will be fixed. Otherwise there is no way to finish a battle! I always encounter that message and game crashes. Thanks.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: BFME2player am 3. Jun 2015, 20:26
Hi
I have recently installed your game and I have a couple of questions about it.
First how do I change the German text to English?
Also I have a similar problem to others in that when I try and play a skirmish it crashes however when looking at how you said to solve I was confused as I can't find the options folder.
Cheers
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 3. Jun 2015, 20:28
Click on the Edain Mod Icon on your desktop. That should open the Launcher. You can change the language there and fix your error.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: BFME2player am 3. Jun 2015, 22:27
Thanks for replying.
I don't have a desktop icon for the mod, I have to click on the ROTWK game icon to get onto the mod.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 3. Jun 2015, 22:36
The installer should have created an desktop icon. You can also run "Edain_Mod_Launcher.exe" in your RotWK folder, same result.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: BFME2player am 3. Jun 2015, 22:42
Thank you for your help :)

EDIT: I have a problem as I played it for a bit and then it crashed.
I loaded it back up and it said "exception message the system cannot find the file specified
and then said to report it and what I did beforehand on here.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: SnobGoblin am 4. Jun 2015, 19:08
Hi everyone, Edain mod demo is amazing!

It works on my computer, but in my friends computer, yes it launches, but when choosing a skirmish or war in the ring menu, it crashes. What files I should check,  to remove this problem?

Thank you for helping, I'd like to play multiplayer match with him  :D
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: TiberiusOgden am 4. Jun 2015, 19:13
when choosing a skirmish or war in the ring menu, it crashes.
Hi. :D  ... Some necromantic power around here. xD
Has he ever tried solution number one?

Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: MacGyver27 am 4. Jun 2015, 22:10
What about the ERROR I posted?? Nobody knows anything? Was it even registered?

Thanks!
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: BFME2player am 5. Jun 2015, 17:45
Hi
I have a problem with my edain mod as i installed it, had a bit of a problem with the non starting games but it i fixed and was able to play it for a bit until i chose gondor on a arnor map and it then crashed. I tried to go on the mod again however it said exception message and then said to put it on here. Please can someone help.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 5. Jun 2015, 18:35
Click Update in the Update-section of the Edain-Launcher.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: BFME2player am 5. Jun 2015, 18:54
Ive clicked update and it still doesn't work
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 5. Jun 2015, 21:16
Try uninstalling the mod and install it again. Start the launcher and check for updates.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: BFME2player am 5. Jun 2015, 23:04
When I try to uninstall the mod it comes up with the same error.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: TiberiusOgden am 5. Jun 2015, 23:07
Are you sure that you have all updates which launcher can provide?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: BFME2player am 5. Jun 2015, 23:31
When I go onto the updates it says it's all updated.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: TiberiusOgden am 5. Jun 2015, 23:34
Still press "update" xD
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: BFME2player am 5. Jun 2015, 23:37
Oh I have multiple times and there is no effect  ;)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: TiberiusOgden am 5. Jun 2015, 23:39
So you are the only one with that problem. Congratulations. :P
One of the last updates should solved "Arnor maps" issue. 8-|
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: BFME2player am 5. Jun 2015, 23:42
Oh the joys!  :P
What do you think I should do

Edit: Thanks for replying
For some reason it works now!
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: TiberiusOgden am 5. Jun 2015, 23:58
For some reason it works now!
Indeed. Positive aura works around me. xD
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: CoRt3z am 6. Jun 2015, 10:04
First  of all hello and congrats on turning an already awesome game into an even more awesome one!

I would like some assistance with changing the language from german to english.I downloaded this :
http://www.moddb.com/mods/edain-mod
I assume it is the last version,but i cannot seem to find any correction of it from searching on google. I only found a video on how to switch 3.8 version and i assumed the procedure wont be the same.Please let me know if its possible to switch since i will lose all the dialog depth given into this awesome mod(Plus i cant even understand  most of the maps :P)
Thanks in advance :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: TiberiusOgden am 6. Jun 2015, 10:07
Start launcher  - section "Optionen/Tools" - "Sprache" and select "English" ...
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: CoRt3z am 6. Jun 2015, 10:42
Start launcher  - section "Optionen/Tools" - "Sprache" and select "English" ...

NVM my last post , for some reason my ROTWK files were unmounted.i re-mounted them and got the game running in english,thank you for being awesome and replying so fast!!!!
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: CoRt3z am 10. Jun 2015, 16:46
Hello again guys and sorry to bother you with yet another problem,i've been searching around for a while and i cannot seem to find any specific topic regarding my problem,only people asking the same thing i do,which is this:
Why do i only get an option to play as rohan/gondor/mordor/isengard?all the other races aren't shown to me.
Number 2: I sometimes get crashes for no obvious reasons,or the game gets stuck in the middle of a match...sometimes it works perfectly and sometimes even after like 3 hours into a match i get a crash and it is so frustrating.Please help if you can !
Thanks in advance :D

Edit : I am using the LOTR BFME 2 ROTWK (Special Edition) ,maybe that has something to do with it ?
Link deleted

______

Edit by Turin: Link deleted, no links to pirated material please.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 10. Jun 2015, 16:57
Number 1:

Because this is a demo. You can't play more factions atm, the missing ones will be in integrated in the future.
The next faction (which will come with the next update) will be the dwarves. :)

Number 2:
It could be that problem, as this version changes some more things ingame and is not the same as an official version. But you can also try to play on lower settings.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: CoRt3z am 10. Jun 2015, 17:06
Number 1:

Because this is a demo. You can't play more factions atm, the missing ones will be in integrated in the future.
The next faction (which will come with the next update) will be the dwarves. :)

Number 2:
It could be that problem, as this version changes some more things ingame and is not the same as an official version. But you can also try to play on lower settings.

I downloaded that version since it has fixed the auto-defeat problem,i assume you recommend lowering the graphics in case the game overloads.I will try that out since my pc isn't one you'd call sufficient :P
Now concerning the factions this kind of confuses me since i've seen other factions...like mirkwood or another elfish one played in older versions like 3.8.1 on youtube .  So im asking this,say i get to download a previous version of the game,should i be able to play those factions??And if so,it should be worth it right?I mean this version is amazing no doubt,but i am so excited about all this new content you guys have added that i cannot wait until i've seen the full content of your work!
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 10. Jun 2015, 17:31
Well, you can also fix the auto defeat problem with a normal DVD. :P

The other factions are available in version 3.81, but this version is not supported anymore and is (as said) an old version and many of the new things are missing there. But you can searchf or a downloadlink, there should be multiple working links in the internet.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: CoRt3z am 10. Jun 2015, 17:58
Well, you can also fix the auto defeat problem with a normal DVD. :P

The other factions are available in version 3.81, but this version is not supported anymore and is (as said) an old version and many of the new things are missing there. But you can searchf or a downloadlink, there should be multiple working links in the internet.

I see,ehh,maybe ill try to be patient and wait for the new content to kick in,its so damn hard though,look at what you did to me! I CANNOT WAIT !!...You really need to  think about releasing a separate lotr fan-made game or something...I cannot even begin to describe how much people would welcome it into their lives !!Especially because its a game made by people who share a deep love for the movies!
Cheers!
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: mixovz am 14. Jun 2015, 20:41
I can only play as Gondor, Rohan, Isengard and Mordor. No elves, no goblins, and no dwarves. I don't know about goblins, but Lothlorien should be a faction, but where is it?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 14. Jun 2015, 20:51
This is just a demo. Therefore there aren't all factions available, the other factions will be added in the future. For more information read this:
http://www.moddb.com/mods/edain-mod/news/edain-40-our-plans-for-2015
The next faction which will be integrated are the dwarves. :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Amarok410 am 16. Jun 2015, 01:22
I recently downloaded and installed the mod.  When i tried to play the mod instead of the advertised more factions, i have less.  I can only play Isengard, Mordor, Rohan, and Gondor.  No elves, dwarves, goblins, or angmar.  The mod does appear to work for the remaining factions. 

The heroes are also not working right.  I made a custom hero who is of rohan design but rohan cant accept any custom heroes at all. 

I updated the mod twice, but it did not fix.  Do you know how to fix this?

[Edit]  I read that this is just a demo and not the full mod :( .  I hope the full version is released soon as it looks so beautiful.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 16. Jun 2015, 09:14
When you're trying to select a CaH with Rohan, there should be a Toolbox popping up in the middle of the screen with further instructions on how to select a CaH. :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: BFME2player am 21. Jun 2015, 15:29
I've been playing my mod for a bit now but it now doesn't let me start games, i can go on already saved games but not new ones. Any thoughts?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: redsoccerball am 29. Jun 2015, 03:04
Hello, when I try to use the "check for updates" feature, I always get an error message "could not connect to server".  I am on the original 4.0 version and want to update to 4.1.  Help?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 29. Jun 2015, 10:44
Is your firewall or Anti Virus blocking the launcher or pinging? To check if the launcher has an internet connection it is pinging our webserver, some bad anti virus programs and firewalls tend to block pinging events, so that the launcher is thinking there is no internet connection. So which Anti-Virus / Firewall are you using?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: redsoccerball am 30. Jun 2015, 02:52
Is your firewall or Anti Virus blocking the launcher or pinging? To check if the launcher has an internet connection it is pinging our webserver, some bad anti virus programs and firewalls tend to block pinging events, so that the launcher is thinking there is no internet connection. So which Anti-Virus / Firewall are you using?

I'm not sure if my response the first try worked, it caused some this or that error...

Thanks for the quick reply!

I just have Microsoft Security Essentials and Windows Firewall, running on Windows 7.  I have allowed all BFME titles (including ROTWK) through the firewall. Not sure what else to do..
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 30. Jun 2015, 12:17
Ok, just run a quick test.
Click on the start menu button and write "cmd.exe" in the searchbar. Open it. Write "ping modding-union.com" in the command line. Is the ping getting through?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Prince Imrahil am 30. Jun 2015, 16:42
Hi, so I re-installed ROTWK and the 2,01 patch. which runds fine. And I just tried re-installing edain, and I get this message;
"The program can't startbecause MFC&1.DLL is missing from your computer. Try reinstalling the program to fix the problem"
Ideas?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: redsoccerball am 30. Jun 2015, 18:18
Ok, just run a quick test.
Click on the start menu button and write "cmd.exe" in the searchbar. Open it. Write "ping modding-union.com" in the command line. Is the ping getting through?

Nope! when I told it to ping, it attempted pinging 4 times, and each time within about 5 seconds said "request timed out". 

"Ping statistics for 185.21.100.70:
Packets: Sent = 4, Received = 0, Lost = 4 <100% loss>"
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 30. Jun 2015, 18:42
Well then there is clearly something blocking pinging on your system. Could be your Firewall, Antivirus or even your router. So you need to make sure that pinging is working and you can download the mod via the launcher.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: redsoccerball am 30. Jun 2015, 21:01
Thanks for the help!

I think you're definitely right... I installed the mod on another computer in the same network and have the same problem.  I have also been attempting to ping websites, and can strangely ping some websites (google, facebook) but not others (including modding-union.com).  I will research more elsewhere how to overcome this issue.

If you happen to know anything about this problem feel free to link me to some solutions. though.


Thanks!!!
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: redsoccerball am 30. Jun 2015, 22:08
Update: My Comcast gateway firewall (not my computer's) was blocking modding union... That part is working now.  There seems to still be an issue with the update though, but at least I got that far
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 30. Jun 2015, 22:16
So you are still getting the same message while trying to update, but pinging via command line is working?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: HypecT am 1. Jul 2015, 16:17
So me and my friend is trying to connect to eachother but it apparently failed and he gets this when trying to join me ''JOIN FAILED Game has detected a mismatch. This means the mulitplayer game has lost synchronization data between the players. It is possible that your opponent has modified their version of the game'' Anyone know a fix to this?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: seanpower2 am 2. Jul 2015, 14:10
I have a problem with the launcher. Everytime I start it, I get "Exception message: Dispatcher processing has been suspended, but messages are still being processed." How do I fix this?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 2. Jul 2015, 16:00
Never heard of this before. Do you have the newest version of .Net Framework installed?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: seanpower2 am 3. Jul 2015, 08:48
When I serched online for a higher version, 4.5 was the high I could find. But when I installed it, it said I already had that version or higher
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: seanpower2 am 3. Jul 2015, 09:33
Okay, so I managed to get .Net 4.5.2, but it still gives the same message. It used to work completely fine 8-|
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 3. Jul 2015, 10:17
http://modding-union.com/cf/mods/edain2/mod/dl51.php?URL=http://modding-union.com/updates/edain2/switcher/edainswitcherinstaller.exe
Try installing the newest launcher version through this, maybe there was something wrong with your download.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: seanpower2 am 3. Jul 2015, 13:02
It cannot overwrite the launcher itself, Once it is launched once, it cannot be edited, moved, etc
So it didn't work either
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 3. Jul 2015, 13:04
Kill the Edain_Mod_Launcher.exe with the task Manager before installing it.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: seanpower2 am 3. Jul 2015, 13:10
The install worked now, but it still gives the error.
Might removing .NET and reinstalling work?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: seanpower2 am 3. Jul 2015, 13:30
Okay, so somehow I managed to get the launcher to respond :D. I'm currently updating the mod
I do however still get the message once I start the launcher. :-|
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 3. Jul 2015, 13:36
Weird. It is somehow connected to your computer setup since you are the only one with this problem. I honestly have no other idea why this error message appears.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: jamesmac57 am 3. Jul 2015, 19:43
the game crashes after 30 seconds on windows 8.1 i have all the neccessary specs for the game and i was able to run 4.0 but since installing 4.1 the game wont work and comes up with the error bfme 2 has stopped working for vanilla bfme 2 rotwk has stopped working and it comes up with the same error for the edain mod aswell please help i used the startup fixer and it still cuts out after 30 seconds and i clicked fix non starting games aswell but it still doesnt get past 30 seconds please help as i really want to play edain 4.1
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 3. Jul 2015, 19:49
Please do not make double posts. The recently released intel graphics driver update, installed through Windows update, seems to make something not work correctly in the game anymore. A lot of people who are using an Intel chip as graphic processors have problems in the last few days. So if you have an Intel graphics chip and another one, like in a lot of notebooks, make sure the game is using the correct one and not the Intel one.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: jamesmac57 am 3. Jul 2015, 19:56
sorry if i uninstall the latest driver update will it work again on 4.0 or 4.1
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 3. Jul 2015, 20:06
Honestly, I have no idea. I have dedicated graphics cards in all of my computers, so I can't test it. Also I am not 100% sure it is related to it, but it seems to be the reason, since a lot of people with Intel chips get it starting in the last few days and Intel released an update as far as I know. As said, simply make sure the dedicated graphics card is used for the game. You can do it in the NVidia settings for Nvidia cards.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: jamesmac57 am 3. Jul 2015, 20:20
it worked and i am sorry for being a pain i was just really excited to play your amazing mod
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Araner15 am 4. Jul 2015, 05:03
So, I did make a topic about this, but I thought about coming here too to see if anyone knows what is the matter. I get this error message every time I try to start up the Edain mod:
(http://i193.photobucket.com/albums/z43/jonx1995/Untitled_zpsjz0k3eft.png) (http://s193.photobucket.com/user/jonx1995/media/Untitled_zpsjz0k3eft.png.html)
I have no other mods besides Edain, so I do not know what is going on.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Exoforce101 am 4. Jul 2015, 14:32
Hello Edain team, I have a problem. The problem is when i downloaded the installaer on moddb I get a crash report
here you van see it
http://gyazo.com/efcd3f42736a0a951f586371466b0980
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 4. Jul 2015, 14:40
@araner: start the mod via the new desktop shortcut. That opens the laucher, which orders the Files correct according to your selected language.

@exoforce: simply download the mod again.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Araner15 am 4. Jul 2015, 21:04
@Turin I am using the launcher and set it on English.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 4. Jul 2015, 21:19
Do you have Patch 2.01 for Rise of the Witchking installed?

And is your game installed in either English or German?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Elite KryPtik am 4. Jul 2015, 21:21
Just to let you know for future referance Turin, the crash that Araner is having is caused by the 2.02 patch lobby music mini mod. Once this mini mod and its files are deleted from the game folder the Edain will work fine with 2.02
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 4. Jul 2015, 21:35
Ah ok. Did not think about this since he said that he did not have any other mod.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Elite KryPtik am 4. Jul 2015, 21:45
Most people don't consider or realize 2.02 is a mod, even I didn't think of this when I had the issue a couple months ago.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Araner15 am 4. Jul 2015, 21:51
Ah, ok, so I need to delete the sound file or do I need to get rid of 2.02?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 4. Jul 2015, 22:43
Get rid of 2.02, it's not a patch, just a balance mod.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Araner15 am 5. Jul 2015, 01:31
How do I uninstall it? It doesn't give me an option to do so.
Edit: Never mind, I got it working! I uninstalled RotWK and Edain, then reinstalled them while downloading the 2.01 patch
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Qallu am 11. Jul 2015, 02:20
http://prntscr.com/7ra0hs
I get this message when I launch the game, what should I do?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 11. Jul 2015, 10:01
Uninstall the complete Game. Reinstall it and make sure that you've installed the actual official Patch before Edain and didnt installed any other modifications.
The unofficial Patch isnt a Patch, its a modification. So Edain cant work with it.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: yfgi21 am 22. Jul 2015, 18:39
Hello
I edain install mod 4.0 and I used the fair for lunching updating once all the update I copied stuck in the download, I Started On games and I noticed a lot of purple texture FAQ primer of the problem come from asset.dat I reinstalled 4 times edain mod but the problem still not resolved. Do you have a solution or can you send me the file asset.dat by email or other means?

(I am using Google translate)

Email: yfgi21@gmail.com or yfgi21@hotmail.com
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: djox am 22. Jul 2015, 21:41
I can`t open the launcher... when I click to open it nothing happens ... i have both games ( tryed running as administrator, tryed reinstaling all for several times, instaling patches didnt work either) what do I need to do ...

PS: also i tryed looking into task manager to look for the changes ...  something pops up and closes in a fraction of a second

Also... no errors or anythin... I start the launcher then nothing happens
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 22. Jul 2015, 22:56
Could be that an Antivirus program is closing the program, since we are not certified developers. Which one are you using?
Also: Do you have .Net Framework 4.5 installed?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: djox am 22. Jul 2015, 23:06
I will try net framework thing... antivirus is not a problem ( tryed it)
Thanks for the quick reply :)

PS: Net framework worked <3 LOVE YA GUYS... keep making the awesome stuff :)

Edit:
I enjoy playing edain mod single player but when I try to join with my friend... we have ``version mismatch`` problem... we tryed patching up games but no luck... any help ?

Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Skeeverboy am 23. Jul 2015, 18:17
1. Have one of you a crack?
2. Have you two Edain Mod 4.1?
3. Have you two Rise of the Witchking 2.01?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: djox am 23. Jul 2015, 23:07
we both have the same games... both have the crack ... both tryed the same patch... both using the latest edain... tryed reinstaling and installing all of it ... didnt work :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 23. Jul 2015, 23:21
Cracks modify the game and can cause different game versions, which leads to assynchrons.
Therefore the problem is the crack.
Only solution: Don't use cracks.^^
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: djox am 24. Jul 2015, 01:29
Yeah but when I try to launch the game trough edains mod , it wont let me until I crack the game :/
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: CurufinweHighKing am 1. Aug 2015, 18:46
Edain Mod Team,

I am having a peculiar problem that no one else seems to be having at the moment. I have tried numerous fresh installs to no avail. Each time I launch the Edain Mod installer it proceeds to update the Launcher to 1.0.0.3 (or something similar) then I launch the launcher again and proceed to try to update the game. Then it tells me that it cannot locate several of the important game files (such as __edain_data.big, __edain_maps.big, etc) and then says that the install probably won't work but it will try anyways and of course after hours of downloading it doesn't work...

So are my files in the wrong location for some reason? I am really stumped, any help would be appreciated.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 1. Aug 2015, 19:07
Did you move the mod folder after installing it? If not check this I wrote some posts ago:
Seems like your registry strings got messed up.
Open the registry via tying "regedit" into the searchbar of your start menu / search function of windows 8.
Check this key "InstallPath" under this path:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Electronic Arts\Electronic Arts\The Lord of the Rings, The Rise of the Witch-king
and check if the install path correct, if not, edit it to the correct path.
Do the same thing for the key "InstallPath" under this path:
HKEY_LOCAL_MACHINE\SOFTWARE\Electronic Arts\Electronic Arts\The Lord of the Rings, The Rise of the Witch-king
If only one of these exists its not a problem, just make sure this key is correct.

Everything should work then.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: jarlaxe am 9. Aug 2015, 14:00
guys ı have problem ı hope you can help me;
when ı try to open game with launcher ı got please insert the correct cd-rom, select ok and restart application error. it happens both edain mod and disabled edain mod but ı can open game with classic rotwk icon and it is open like edain mode .  I got rotwk unoffical patch 2.02 before both ı unistall everything about this patch and bfme 2 and rotwk ı even delete regedit files etc. then ı reinstall bfme 2 version 1.06 and rotwk 2.01 dont do crack and using image files. I download edain demo 4.0 and install it then uptade all latest on launcer ,now ı check my launcher version is 1.0.0.3 btw,ı hope you can help me waiting your answer. ı played it like 2-3 hours my game stop 2 times control panel says 'not responding' it never happaned before edain mode you can help me about that either.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: legoras001 am 12. Aug 2015, 23:10
como hago para actualizar edain mod 4.1 a la version 4.1.1 yo actualizo pero no me sale esa versión nesecito ayuda
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: TiberiusOgden am 12. Aug 2015, 23:23
pero no me sale esa versión nesecito ayuda
Entonces es posible que ya tienes 4.1.1 version.
Tienes, por ejemplo - Thorin con la armadura en último nivel?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: eldarion002 am 14. Aug 2015, 18:59
Hello,

I have a problem when I want to update the mod, I have an error message that appears:. "Could not connect to server"
What to do to be able to update the game?

Thank you in advance !
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 14. Aug 2015, 19:13
Make sure your firewall are anti virus is not blocking the launcher. The launcher is using a ping to check if it is online, if this ping fails it gives you this messaging. So allow pinging and internet access for the launcher and everything should work fine.

I am going to release an update for the launcher within the next few days which also alternates the way it searches for updates so that it is also possible with computers where pinging is blocked, internet access is needed nethertheless.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Spark am 15. Aug 2015, 06:58
Okay so I tried making an exception for AVG and I still can't connect to the server to download the 4.1 demo. I know I'm not the only one with this problem so if I can please get some help some possible solutions, that would be great. Because I'm just about ready to give up.

Or alternatively could someone just point me to a download for 4.1 without a server connection?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 15. Aug 2015, 11:21
There is no need to create multiple new threads because of this, so I deleted one and merged the other with the support thread.
AVG is a crappy AV, which blocks everything even if you make exceptions except the creator is making agreements with them. Clearly an AV creator who is all about making money instead of a quality product. So best solution would be to use a lightweight AV from a good developer which is not playing your mommy and forbidding everything you do on your computer, blocking pinging for example is just stupid. The best way to prevent viruses is using your brain.
If you do not want to use a proper AV then you have to wait. I am going to release a launcher update this weekend which has a second way to check if it is online so people with blocked pinging events can also update the mod via the launcher.
A setup download for 4.1 is not available.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: eldarion002 am 15. Aug 2015, 11:51
Even when I disable the firewall I have the same error message ...
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 15. Aug 2015, 14:05
I just released the update. Since you wont be able to download it via the launcher itself, you can download the launcher update here:
http://modding-union.com/cf/mods/edain2/mod/dl51.php?URL=http://modding-union.com/updates/edain2/switcher/edainswitcherinstaller.exe
Updating should be possible even with blocked pinging now, even it is still not possible then there is still an AV or firewall blocking the launcher in total, not just pinging.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: CragLord am 16. Aug 2015, 22:19
When I go on news at launcher, and then go to new one "Launcher 1.1.0.1 released", on bottom of text there is READ MORE >> link. When I click on that link, eadainswitcherinstaller. exe starts to download. Is this intended?

P.S. Nice music! :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 16. Aug 2015, 22:29
Yes.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: eldarion002 am 18. Aug 2015, 18:34
I installed the link you sent me, but I feel that I am still under 4.0 because I have no dwarves among the playable factions ... I just noticed the little music, nice to passage of the launcher.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 18. Aug 2015, 19:09
Search for updates, there should be a mod update available.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: eldarion002 am 18. Aug 2015, 19:21
Yes but it always strikes me: Could not connect to server ...
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 18. Aug 2015, 19:39
Did you try it after updating the Launcher? It is now working if pinging is blocked. If it still says could not connect than your firewall or antivirus is still blocking the Internet connection of the Launcher.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: eldarion002 am 18. Aug 2015, 20:56
Yes I installed the update that you sent me a link. And even disabling public or private firewall that strikes me the same error message. And antivirus avast I just I did not at all affected for a long time whereas before the mod worked very well, I could update it without the error message: Could not connect to server ...
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 18. Aug 2015, 20:59
Weird, it should work easily then. I am going to send you some instructions how to get the update manually via PM.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: TheKingofAngmar am 10. Sep 2015, 04:59
Hello, the mod seems awesome but everything is in German for me. Is there a way to fix this?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Fíli am 10. Sep 2015, 05:03
Change the language via launcher. ;)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Galanur am 11. Sep 2015, 18:43
I got an issue.

When I click the Play Icon on the edain launcher the game end up not starting, what I did wrong? I´ve been trying to look around for info on this post but I can´t see any similar problem around.


Thank you
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 11. Sep 2015, 18:44
Go to options in the launcer and try the fix there. :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Galanur am 11. Sep 2015, 19:05
and if that doesn´t work? cause I can´t start edain nor the RoTWK from the launcher... it seems it doesnt read and dont start..
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 11. Sep 2015, 19:09
Please write what is happening exactly if you click the play button in the launcher.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Galanur am 11. Sep 2015, 19:10
I enable the mood (edain) then click play.... I see the mouse cursor timing reading the program I started then nothing happens, just like if I didnt asked to started it... i tried the same with he Rise.... same stuff... doesnt start the game
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 11. Sep 2015, 19:22
You dont even get the games splashscreen? Thats weird. Try reinstalling BFME 2, the Addon Rise of the Witchking and the mod.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Galanur am 11. Sep 2015, 19:40
if I start the regular versions bfme 2 and RoTWK they all work just fine when I click to play, just not with the launcher
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Galanur am 11. Sep 2015, 19:47
Well apparently the Edain is what is blocking all... I did playing bfme and RoTWK today earlier... soon I started edain the game simply dont run, not even the splashscreen...
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 11. Sep 2015, 19:56
You can also run the mod through the original RotWK shortcut, if that is still working. Still weird, since the launcher does just start the games exe, same as when you click the desktop shortcut to the game.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Galanur am 11. Sep 2015, 20:20
I played bfme 2 with all the patches and was ok and havent tried after installing the RoTWK patch 2,0 something... I think that patch bugged my game as I unistalled the Edain and still dont work... so apparently the root of the problem is hopefully the RoTWK
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 11. Sep 2015, 20:26
On which patch to you play?
Patch 2.01 is the last official patch - 2.02 is an unofficial patch, so it's also just a mod. Two mods never work together,. So:
Install Rotw
Install Patch 2.01
Install Edain
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Galanur am 11. Sep 2015, 20:30
I did installed patch 2,01 but with ea something on it..... its odd, im installing the RoTWK again and see what happens... test if the game runs and after that the edain
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 11. Sep 2015, 20:35
The thing is: You need to have the correct version of the patch! It needs to be the one for the language you have installed. There are also versions for the disk version and the digitally distributed one.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Galanur am 11. Sep 2015, 20:45
RotWK sucessfully installed and working... now checking edain
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Galanur am 11. Sep 2015, 21:12
Its working, ty guys :)

I hope I wont get many more errors but I´ll ask in case happens...

May the Valar show you mercy to all in game......cause I will not :P
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Galanur am 11. Sep 2015, 22:34
ok another issue showed up

I only have
- isengard
- gondor
- rohan
- mordor

As part of the armies I can choose... where is the rest?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: CynasFan am 11. Sep 2015, 22:41
If you have updated to last Version there should be dwarves also, it works about the Launcher.
The other Factions aren´t avaible because it is a demo an they will be patched later, next is Lorien.
I hope that helped and sorry for my english, I´m natural german. xD
Greetings, CynasFan
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Galanur am 11. Sep 2015, 22:44
the english works perfectly...

Question.... is there a gundabad faction? I would love to get those around, like base force..
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: CynasFan am 11. Sep 2015, 22:54
I wanted to say that new Updates only works over the launcher. If you haven´t updated about him, I think you play 4.0, the first Version of new Edain generation.

Gundabad comes, but probably it comes at last faction, because it have the greatest differents to the normal Edain gaming and the most new designs and skills.
But there are also many updates by the Team what they do with the factions. Only you have to look in the Edain News. ;)
Greetings, CynasFan
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 11. Sep 2015, 23:00
Everything about the factions is described in this article:
http://www.moddb.com/mods/edain-mod/news/edain-40-our-plans-for-2015
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Galanur am 12. Sep 2015, 01:26
hmm if you guy wanna go movie accurace maybe you can give iron hill dwarves a new unit, dwarf phalanx (those with shield and spear like the movie)

Also I found an error in the map... Iron hills the southeast  corner ther eis a nearby work site, npcs attack that thing, I got my ally comp stuck with least 300 modelss...
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 12. Sep 2015, 10:23
Please write bugs in the bug sections and suggestions in the suggestion section. This here is the section for support, therefore when someone has problems.

We also don't really like the movie design of the iron hills and will stick with ours. :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Vingilot am 27. Okt 2015, 22:10
Hello fellow Edain Mod players. I have for the last couple weeks been unable to play the Edain mod or ROTWK. I keep getting a DirectX error but I do not have SweetFX installed. I have tried the 'Fix Non-Starting Games' option in the launcher with no success. I have tried uninstalling and reinstalling the mod numerous times and have even installed the base game and ROTWK from scratch and the problem has persisted.

I use Windows 8.1. I tried the game in Windows 10 and in compatibility mode with no success. Any help is greatly appreciated.

Cheers.

Edit: Here's exactly what the DirectX error says:
"Please make sure you have DirectX 9.0 or higher installed. Also verify that your video card meets the minimum requirements, and that you do not have hardware acceleration disabled in the Display control panel."
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: godlikegerbil am 3. Nov 2015, 05:51
i love this mod but when i installed it. it broke the gondors fortress on the original bfme2 witch i still play with my friends but it makes us go out of sync when we play for more then 25 min. the problem is that the fortress is invisible for everything but the door and addons
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Adamin am 3. Nov 2015, 09:22
Hello fellow Edain Mod players. I have for the last couple weeks been unable to play the Edain mod or ROTWK. I keep getting a DirectX error but I do not have SweetFX installed. I have tried the 'Fix Non-Starting Games' option in the launcher with no success. I have tried uninstalling and reinstalling the mod numerous times and have even installed the base game and ROTWK from scratch and the problem has persisted.

I use Windows 8.1. I tried the game in Windows 10 and in compatibility mode with no success. Any help is greatly appreciated.

Cheers.

Edit: Here's exactly what the DirectX error says:
"Please make sure you have DirectX 9.0 or higher installed. Also verify that your video card meets the minimum requirements, and that you do not have hardware acceleration disabled in the Display control panel."

I think Win10 does not install old Versions of DirectX automatically, so you have to install DirectX 9 manually.

It should be packed on your BfMe Game Disc, if you can't find it online.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: CragLord am 8. Nov 2015, 22:41
Patch 4.2 Updating:
Why is this happening? 7 GB is needed for start of updating and 550mb is size of update? This never happened before to me...
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 8. Nov 2015, 23:19
It's mostly for safety purposes.
No matter how big the download is, you always needed 7 GB free space.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 9. Nov 2015, 11:40
The full release will contain a size up to 5-7gb, so its only a safety purpose.
Make sure, that you have 7gb free space on your drive (and its not good for the health of a drive, if you have less then 7gb on it...)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Kizuato am 9. Nov 2015, 16:28
Hello Edain Team ... First of all i wanted to thank you for all the hard work you'v put into this mod .. Its really the greatest mod for BFME 2 so far ..

But I'v got some serious problems from that last patch and adding of Lothlorien.
First one is really well .. game breaking (for me atleast) ... I just cant play rohan anymore .. well i can but .. I will be defeated after a couple of second ... Rohan keep or castle just do not spawn .. I dont know if its just me or anyone else is experiencing this weird bug .. but yeah .. I really love Rohan .. even they are a little bit weaker than for example Mordor or Lothlorien (just my opinion ... they could get a little buff).

And the second one is just my little note for that -20% health and catapult buff ... Well the catapults were giving me much troubles even before this buff and my rohan people were dying really fast under the big ballista bolts of Isengard ... This could use a little nerf in my opinion .. but hey .. your mod ... am just a little one here .. still lovin-it thou.

Soo .. thank you for your time (if you read this of course) .. aand yeah .. thanks for all i quess ...Great work so far

Your devoted fan Kizi  :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 9. Nov 2015, 17:54
Zitat
Rohan keep or castle just do not spawn
Do you play on a selfmade custom map? Next question: Do you play with a crack?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: CragLord am 9. Nov 2015, 18:53
Thanks for info. :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Kizuato am 9. Nov 2015, 19:20
Nope I'v been playing normal maps (edain team maps or native one) ... I just dont know what happens ...  I'v been trying to click ''update'' and think that some content just do not download .. but no ... everything is downloadet and in place
I just dont know
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Weirdone am 22. Nov 2015, 12:28
I only have the battle for middle earth1, I tried instaling edain mod, i installed it, turn on the launcher and when i click play it just tells me there is an error and it turns of, do i need the battle for middle earth 2 and rise of the witch king to play edain or should i try reinstalling?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 22. Nov 2015, 13:03
Zitat
do i need the battle for middle earth 2 and rise of the witch king
Yes.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Rockyeahh am 8. Dez 2015, 21:15
Hi I downloaded Edain mod 4.0 but instead of giving me the install file it gave me a file that I cannot open. It is called edain4.0-demo[1]
It says the file type is 0-DEMO[1] File
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: CragLord am 21. Dez 2015, 14:23
Just one short question.
Lately I have more frequent game crush with this message:

(http://s5.postimg.org/jtrkn6omf/Game_crush.png)

and after that one, this one pops up:

(http://s5.postimg.org/e6zt3gbhj/image.png)

Is there something I can do about this?

Regards,
CragLord
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 21. Dez 2015, 14:27
Try to use lower settings. This normally heppans when the engine is over-worked.^^
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: CragLord am 21. Dez 2015, 14:40
Thanks Gnomi. :)

Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: GooDHaLF am 6. Jan 2016, 19:04
Hello guys!
I've just installed tunngle and wanted to play online. I started the game through tunngle and then clicked ''multiplayer'' and ''online''  At this point a message says ''This computer has the windows xp sp2 firewall enabled. An entry must be added to the firewall exemption to play lord of the rings.
The problem is that i have a windows 7 computer, also i've tryed to turn the firewall off but the message still occurs.
Thanks for taking time to read.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 6. Jan 2016, 19:05
You can't play online - EA Games shut their servers down a long time ago. You have to use programs which simulate a lan network like Tunngle (or Gameranger or hamachi) and use the network area afterwards. :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: GooDHaLF am 6. Jan 2016, 19:12
Haha solved that problem now :D Im in the lobby area and cant join a single one. it says that they maybe modified their game. But i think im might unupdated. I have the version 2.01. What do you think the problem is?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 6. Jan 2016, 19:21
Did you also update the mod? Start the launcher and click on Update. Do this again and again until it says that there are no more updates without installing anything. You need to update the mod at least twice - one time for the laucher and one time for the mod. Afterwards it just checks if there is another new update (which most likely is not the case, as you've just updated the game) or if some of your files are damaged, which can happen while downloading them. In both cases the launcher will download the missing/damaged files. :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Walküre am 6. Jan 2016, 20:47
But i think im might unupdated. I have the version 2.01. What do you think the problem is?


Do you mean the version of your ROTWK copy? The one indicated in the Options?

If it is, it's definitely right, then.
The number '2.01' refers to the version to which your vanilla game (ROTWK) is updated (if you have installed the needed and OFFICIAL 2.01 patch of ROTWK).
The Edain Mod (regardless of the version) doesn't change the version of your ROTWK.

If you miss something that has already been released or if you have other similar problems, just update the Edain Mod Launcher as Gnomi wrote.

Remember, though, that it's absolutely fine if your vanilla game (ROTWK) is updated to the 2.01 version  :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: mat9380 am 11. Jan 2016, 04:39
I can not play maps with missions?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Henlo am 11. Jan 2016, 21:33
Hi!
First time posting and first time i'm trying a mod for this game.
Cant get it to work though.. I've been at it for hours now and can't get it to work.
When I launch a skrimish, the game crashes. I've unistalled RoTWK and the mod, re-installed RoTWK, patched it through the launcher and then re-installed the mod. I've done this procedure twice but nothing seems to work. I got in to the gameplay ONCE when Gondor was pre-selected in the skirmish menu, but when i exited that game to start a new one, it crashed again, regardless of which fraction i elected.

So I've pretty much tried all the basics, including the steps suggested in the FAQ and other tips I've found in this thread such as updating the launcher... still game crash when I click play. What happens then is that Windows is telling me that the the program suddenly crashed, no mor info :/
Help, please?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 11. Jan 2016, 21:42
On which graphics settings are you playing?
Which graphics card / chip do you have? Which OS are you using?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Henlo am 11. Jan 2016, 21:51
On which graphics settings are you playing?
Which graphics card / chip do you have? Which OS are you using?
Complimentary information: I also get this message about runtime "this application has requested the runtime to terminate it in an unusual way" plz conatct application support team".

Im running on oldschool windows 7, I've put all graphic settings on low just to make sure. Currently I'm running the game on my laptop since I travel a lot and this is the computer I most often use, graphic card is shitty GeForce GT620M. I can run the original game at high settings with no lag or probs though.

Btw, I just tried to start war of the ring and that works, I get to the overview map and all. I can also start and fight the battles in real time in the war of the ring-mode. But as soon as I try Skirmish... crash.
Thanks for replying!

Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: mat9380 am 11. Jan 2016, 23:09
? o rispond on my post.. when i tray misions it chras ,,. i dont have rivndel no angmar.. so i am asking for like 4 time is ther somthing wrong or it just like this new wersion of edain? also.. is ther mod or somthing from Edain for BFME 1or 2 not ROWK . thanks
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Melkor Bauglir am 11. Jan 2016, 23:45
Actually Odysseus already answered you in "Ask the Edain-Team". Also it's kind of hard to ask 4 times with 3 posts in total. ;)
Now to your question: Imladris, Misty Mountains and Angmar aren't released yet, meaning only Gondor, Rohan, Isengard, Mordor, Dwarves and Lothlorien are playable right now.

Greetings
Melkor Bauglir
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Walküre am 11. Jan 2016, 23:52
? o rispond on my post.. when i tray misions it chras ,,. i dont have rivndel no angmar.. so i am asking for like 4 time is ther somthing wrong or it just like this new wersion of edain? also.. is ther mod or somthing from Edain for BFME 1or 2 not ROWK . thanks


What kind of missions are you trying to run?
Of course you don't have Angmar and Rivendell, this is a DEMO; the latest faction to be released was Lothlórien, and for the other ones you have to wait like everyone else.

This is a Modification of ROTWK (updated to the 2.01 patch); you necessarily need also BFME2 to play the game, since ROTWK is an expansion of the same BFME2.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: mat9380 am 12. Jan 2016, 00:24
? o rispond on my post.. when i tray misions it chras ,,. i dont have rivndel no angmar.. so i am asking for like 4 time is ther somthing wrong or it just like this new wersion of edain? also.. is ther mod or somthing from Edain for BFME 1or 2 not ROWK . thanks


What kind of missions are you trying to run?
Of course you don't have Angmar and Rivendell, this is a DEMO; the latest faction to be released was Lothlórien, and for the other ones you have to wait like everyone else.

This is a Modification of ROTWK (updated to the 2.01 patch); you necessarily need also BFME2 to play the game, since ROTWK is an expansion of the same BFME2.
i ask is ther for other parts not this on :/ i will wait but some people had angmar and i am new.. and forum is bit mesy to reply or find somthing sorry.. so is ther mods or somthing for other parts like bfme 1 ? cose i just soo this video and argue down on it that is stolen? just trayng to found out more obut Mod . cose i relly like it and if it gona get beter i will stick to it .. https://www.youtube.com/watch?v=_L2JCzt1-9E
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Walküre am 12. Jan 2016, 00:48

Who had already Angmar?
There are Beta Testers and Moderators who have already this faction, because they have to test it and give possible suggestions for its improvement.
But, as far as I know, no one can show something on YouTube or other websites until the official release, or with the specific allowance of the Edain Team (as it happens with the YouTuber RuudDevil, for example).

The forum is not messy at all; you just have to get used to it.
It's exactly organised in different sections to help people find answers to their questions.

Regarding that video, I can't speak for the Edain Team, but, if you have used some of their material without their permission, this is definitely something not allowed.
Many other Mods that consisted of 'stolen' material were legitimately shut down on ModDB for the same reason.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: mat9380 am 12. Jan 2016, 01:02

Who had already Angmar?
There are Beta Testers and Moderators who have already this faction, because they have to test it and give possible suggestions for its improvement.
But, as far as I know, no one can show something on YouTube or other websites until the official release, or with the specific allowance of the Edain Team (as it happens with the YouTuber RuudDevil, for example).

The forum is not messy at all; you just have to get used to it.
It's exactly organised in different sections to help people find answers to their questions.

Regarding that video, I can't speak for the Edain Team, but, if you have used some of their material without their permission, this is definitely something not allowed.
Many other Mods that consisted of 'stolen' material were legitimately shut down on ModDB for the same reason.
oh. thanks.. i ment on german and eng. when i press Eng. it drops me on wery difren look of this site but whit German and eng. that why i sed it messy. and thank for answers.. I am just interested and relly happy sombody is improving game as it sm game was good but now it looks like BFME 3 and exps.  [uglybunti] and sory . i am rell new in this.. i just found out you can juse mod like 1 wik ago  :o
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Walküre am 12. Jan 2016, 01:11
Almost all the English boards have a '[en]' before their title, which means that they are in English.

There is also a tool that you can use, at the top of the homepage, on the right, that allows you to see only the English boards (and consequently their related threads) of Modding Union.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Henlo am 13. Jan 2016, 19:50
No one knows what I could do? Really want to play this mod :/
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: mat9380 am 13. Jan 2016, 23:29
No one knows what I could do? Really want to play this mod :/
well say..what is it?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: mat9380 am 13. Jan 2016, 23:35
No one knows what I could do? Really want to play this mod :/
I had chras.. make sure  you got vers bfme2 1,6 v . and rwok 2,0 i think? but make sure you Unistal all and delet file from your hard disk.. then instal agen.  get mini images for bouth + run bouth games bi fore pach. and then intal from edain luncher game . run it.. and get out and run up date and up date i had to like 5 time :3 . tray that
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Adamin am 14. Jan 2016, 09:39
No one knows what I could do? Really want to play this mod :/

Could be a Problem with the original bfme-profile. Have you tried the startup Bug fixer in the launcher? It should reset your profile.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Yung_Doc am 15. Jan 2016, 07:03
I have bfme2 at 1.06 and rotwk at 2.01, i was having this issue when i downloaded the 2.02 which fixed it but since the edain mod won't work with it i switched it back to 2.01, whats the solution here?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Walküre am 15. Jan 2016, 07:22
I have bfme2 at 1.06 and rotwk at 2.01, i was having this issue when i downloaded the 2.02 which fixed it but since the edain mod won't work with it i switched it back to 2.01, whats the solution here?


Yes, the 2.02 patch is not official and thus is likely to create issues in starting the Edain Mod.

Are you sure that you deleted all the files related to that patch?
Do you have any other Mod/Submod or unofficial patch installed in the ROTWK folder?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Yung_Doc am 15. Jan 2016, 18:47
I have no other mods or subs mods just that 2.02, but i forgot to switch bfme2 back to 1.06 and that solved that issue but now i have this issue.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 15. Jan 2016, 20:33
That is still an issue with 2.02. Again, 2.02 is NO official patch, just another mod. Edain Mod wont work with 2.02. You only need the official patch 2.01.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Yung_Doc am 15. Jan 2016, 20:47
That is still an issue with 2.02. Again, 2.02 is NO official patch, just another mod. Edain Mod wont work with 2.02. You only need the official patch 2.01.
I figured that part out but now when i upgrade units  and build structures they turn invisible and so are some of the enemy  units.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 16. Jan 2016, 12:55
Press "update" in the launcher. It seems as if the unofficial patches have deactivated our asset.dat
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Kalmakil am 23. Jan 2016, 15:28
Hello guys, thank you for this excellent mod. My problem is that Imladris, Goblins and Angmar do not appear in the faction list in the game, in skirmish as in war of the Ring modes. Is it a known problem ? Strangely that's the only awkward thing i have seen for the moment.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Skeeverboy am 23. Jan 2016, 15:38
Angmar, Imladris and Goblins aren't released at the moment, but Angmar will come with the next Patch.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: pauldums am 25. Jan 2016, 23:14
Hi edain team ! Hope that work on 4.3 is going well :)

What do you advice me to do when a skirmish is crashing at the very beginning : the game is loading but i can't see the starting base. I have the error : " Windows programm has stopped working"
I think that it is due to my graphics cards (Intel HD Graphics 5500 and AMD Radeon R7 M360 on windows 10).
Hoho96 advised me to put lotrbfme2ep1.exe and game.dat in high power in the  AMD switchable graphics panel.
It works but the game is very very slow (the graphics are in very low) so it's impossible to play multiplayer games.

Any ideas ?

Thanks for your time.


Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Henlo am 27. Jan 2016, 15:06
Hi!
Just want to say that somehow, my problems were solved and I'm now able to enjoy playing the mod. Thanks so much Edain team for your fantastic work!
My problem was that when I choose skrirmish and the AI was set as "random" faction, the game crashed when I tried to launch the skirmish.
So if someone is having the same problems as me with, try to appoint a faction to the AI, don't let it be at random.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 27. Jan 2016, 15:17
This only happens if you gave them a not available create a hero before. The random faction is working fine otherwise.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Haguiv412 am 5. Mär 2016, 12:12
Hi
When I want to play a battle I can only choose from Gondor, Rohan, Isengard and Mordor.
How can I select the elves or dwarves?
Thanks for your support!
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 5. Mär 2016, 12:12
Start our launcher and update the mod twice. (the first update is for the launcher, the second for the game)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Haguiv412 am 5. Mär 2016, 12:23
Did it and it worked, thank you sir!
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Giamos am 30. Mär 2016, 19:53
Hi, I'm getting the 3:30 auto-defeat bug, didn't update Edain yet because it took me 3hours to update yesterday and I still had to reinstal the game (had a "insert correct CD" message).

I tried the fixer by Thorongil and then the regedit/ergc method nothing worked so far.

Will updating edain work ?

Using windows 10 and SmokingMan's mini-image.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Gnomi am 30. Mär 2016, 20:35
Giving support for illegal versions could get us sued, therefore we're not doing it.
I'm sorry, but the only thing you'll hear is: Get a legal version.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: lord_ellessar am 3. Apr 2016, 19:22
I had put my game in German to be able to use worldbuilder then I poured out back to English but the texts stay in German :/
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 3. Apr 2016, 19:26
- Merged -

Close the Edain launcher. Open it and switch language.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Leri_weill am 12. Apr 2016, 16:21
Path of the Edain crashes whenever I try to launch the map. What location shall I choose to start ? Do I have to be the only player on the map ?

EDIT : my bad, I had to delete a file. It's ok now :D
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: maarwun am 14. Apr 2016, 17:09
hi guys,
since i've updated to the most recent version (4.3.1) i've been getting the following error every time i open the launcher. I can still play the game, but it crashes alot (like at least half of the matches i play)
i've tried to add a screenshot of the error message as an attachment, but i'm not sure if it worked...
the error message also sais that i have to post the log, but thats really long, so i'm going to put it in a spoiler (i really hope i do that right too)
so, how can i fix this?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 14. Apr 2016, 17:13
The launcher can't get access to the options file of the game, that's why the error is appearing. Did you set it to copy protected?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: CragLord am 17. Apr 2016, 17:38
Just one question, I have reinstalled mod and after installation, my launcher is working (I can play game), but  I noticed these labels and text which are empty (http://s23.postimg.org/3qvikzwsr/Launcher.jpg),
when I click on them and later I click on READ MORE >> option, this happens (http://s23.postimg.org/5wptfi097/Lanucher1.jpg).
What have I done wrong?

Regards,
CragLord
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 17. Apr 2016, 18:04
The news didnt get downloaded, probably because pinging is blocked on your computer. I am going to do a workaround for that in the next version
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: maarwun am 18. Apr 2016, 19:04
The launcher can't get access to the options file of the game, that's why the error is appearing. Did you set it to copy protected?
where and how can i do that?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 18. Apr 2016, 19:12
Try the "fix non starting game" option in the launcher and then restart. It should fix that issue too. Be aware though that all your savegames and custom maps will be deleted if you do so and your settings will be resetted.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Statik am 23. Apr 2016, 13:01
Hi
I have a question
i see many people playing edain mod with what looks like a "new selection layout" beneath their units, wich is the same color as the color u chose for your faction, but in mine it is still "the old one"
i dont know if im explaining myself right but i hope someone can answer me this pls
Thank You very much, and keep up the good work edain team  :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: bigeddu am 25. Apr 2016, 14:44
Salutations

I own legal copy DVDs of “The Battle for Middle Earth, The Battle for Middle Earth II, The Battle for Middle Earth II Collector’s Edition” games and an Origin installator for The Battle for Middle Earth II, Return of Witch King (no optical disc required to play).

I recently had a brand new* OS and Software installation in my computer (after a disappointing Windows 10 experience).

My OS is a 64bit Windows 7 Ultimate version up to date. I am using a licensed DAEMON TOOLS Lite version for ISO / MDS images mounting.

Here is the problem:
When I try to run the games I always get the “please, use the correct CD-ROM, choose accept and start again the application” message. I get this message with ISO images mounted or with the original DVD in the optical tray. Even the RoWK displays the same message, and the installation is made from ORIGIN!

So I have to choose:
1.   I play with a no-DVD patch and, therefore I reject playing multiplayer or the EDAIN MOD
2.   I can’t play but I try to fix the problem.

Of course it is number 2 but after trying the “option.ini” thing, downloading a NO-DVD MDS mini-image and installing the EDAIN MOD 4.3 (you know, for the “maybe it fixes the problem” thought) with no success, I run out of ideas.
I think it must be a DRM or Secure Disc related issue but it’s only to blame Microsoft for something ;-)

So, is there somebody with a challenging spirit who are willing to help?

I understand Spanish, English and some German so feel free to write in any of those languages. Any contribution would be appreciated.

* Formatted partition.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Walküre am 25. Apr 2016, 16:42

This section is supposed to be the place in which general discussions about games and gaming itself take place. It's not thus the proper place to seek for help. Therefore, I will merge this thread with the main support topic of the Support Section  ;)

MERGED
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: bigeddu am 27. Apr 2016, 16:39
Thank you "DieWalküre". And sorry for the misplacing ^^U
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Éomer Éadig am 17. Mai 2016, 12:51
Hi Edain team,

I have a strange error on my laptop. I could play your mod fine up until now, but now I have an issue, which is strange since I did not change anything. After launching the game, the startup process is normal but when I come tot the menu screen, the game crashes. I get a notification that the game has stopped working and the game exits.

Now, on the menuscreen, I can see the menu buttons for a split second but when the background should normally show up, the game exits.

I have already tried the "Fix Non-Starting Games"-button, but all it did was revert my resolution to 800*600 but that did not resolve the issue. I am, however, still able to play the ordinary Rise of the Witch-King game, where this error does not occur.

Would you know what could cause this?

With kind regards and thanks,
Éomer Éadig
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 17. Mai 2016, 14:22
Use the forums search. You either updated to windows 10 or updates your Intel graphics chip driver. If you have a dedicated graphics card then make sure this graphic card instead of the Intel one is used. You can do that via the drivers menu. You need to install an roughly two year old windows 8.1 graphics driver if you only have the Intel chip.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Azoia am 19. Mai 2016, 01:17
Hi. Im new to this forum and mod. I installed the lastest version (4.3). the launch launches, the updates a update, but when i clack play the game crashes and this appears:

"An upgrade mask references Upgrade_TreeBeardLeaders hip, which is not an Upgrade

Error parsing field 'TriggeredBy' in block 'Object' in file
'data\ini\object\goodfaction\units\ents\treeberd.ini\, line 336.


Error parsing field 'TriggeredBy' in block 'Object' in file
'data\ini\object\goodfaction\units\ents\treeberd.ini\, line 336.

Error Parsing INI Block '              TriggeredBy' in file
'data\ini\object\goodfaction\units\ents\treeberd.ini\, line 336.
7 addresses
(unknown)(0):game.dat+239838 Debug::PostStaticInt+3390
(unknown)(0):game.dat+2346667
StringBase<char>::~StringBase< char>+262887
(unknown)(0):game.dat+2376649
LineSegment2D::~LineSegment2D+20490
(unknown)(0):game.dat+6541831 Xfer::operator==+119943
(unknown)(0):kernel32.dll+78730 BaseThreadIntThunk+18
(unknown)(0):ntdll.dll+235778 RtlInitializeExpectionCh ain+99
(unknown)(0):ntdll.dll+235733 RtlInitializeExpectionCh ain+54

Because of the severity of this error the game will now exit."

DAMN THAT TOOK ALOT TO WRITE

i can still play the vanilla game (witch king)

how can i fix it?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: The_Necromancer0 am 19. Mai 2016, 08:42
Make sure of the 2 following things:
-No mod on ROTWK (including the UNofficial 2.02 patch)
-BMFE 2 is 1.06
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 19. Mai 2016, 09:58
You've installed the unofficiell patch 2.02, which is only another mod. Delete it and everything will be fine.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: lordglorfindel am 23. Mai 2016, 15:11
Hi.I updated the game when 4.3.2 released.After update, game starting to make texture crash like flexible slashs.And i noticed that arnor hero Carthaen's image (leftside of the screen) is purple.I have already uninstalled-installed mod .Any suggestion?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Walküre am 23. Mai 2016, 15:31
Purple textures indicate that some of your files are corrupted for many possible reasons. Uninstalling and reinstalling everything again is generally what they commonly suggest. That kind of issues could also be caused by the usage of an illegal crack or by an interference with another Mod.

Do you have an official (legal) copy of BFME2 and ROTWK? Do you have those two games respectively updated to the 1.06 and the 2.01 versions (the official patches)? Do you have other Mods installed for ROTWK that could create problems?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: lordglorfindel am 24. Mai 2016, 06:30
My game is unoffiacial.And use image files with daemon tools.Could be any reason because of Botta Mod?Before uptade they were working together well.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 24. Mai 2016, 09:57
Yes this could be the reason. Uninstall botta.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: lordglorfindel am 25. Mai 2016, 19:33
uninstall and reinstall didn't solve the problem.It causing from beorning's human form.They become invisible and after that Slash starts.Also i saw same thing after i build Imladris Outpost in Arnor.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Walküre am 30. Mai 2016, 22:27
As already stated in the previous posts, if it's not another Mod that causes those issues, it means that your files are corrupted because they were probably installed incorrectly for some reasons. The fact that your copies are unofficial could be behind these problematics.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: BigMacTheory am 18. Jun 2016, 20:09
Hi everyone,

First thanks for this awesome mod, fantastic work.
Everything works fine with me except one thing : while playing in Skirmish/Epic Battle setup, when my game last more than about 1h15, the command points counter disapear and it gets impossible to me to build any more units.

Is it normal ? Can I fix it ?

Thanks !
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Mrdstephe am 4. Jul 2016, 22:10
I downloaded edain demo and edain mod launcher i entered the game i pressed to play but it said that the system could not find the file specified
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Walküre am 4. Jul 2016, 22:19
I downloaded edain demo and edain mod launcher i entered the game i pressed to play but it said that the system could not find the file specified

I deleted the poll as it was completely unnecessary. If you want to open a new thread, you just have to choose the NEW TOPIC option at the top of the board.

I also merged the thread with this one; your request for support doesn't belong to the Edain Bug Reports section. Anyway, just wait and you will soon receive support here  :)

--- MERGED ---
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: calixoxx am 9. Jul 2016, 23:46
Any idea for launcher error 'Launcher not running in defaults game path'?

It says im fully updated with 4.3.2, but when i try to multiplayer through game ranger it still says mismatch. i dont know if its because of the launcher issue or not.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: lordoflinks am 10. Jul 2016, 01:19
When I disable the mod and attempt to play vanilla it gives me a CaH error
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 10. Jul 2016, 12:06
Please make a screenshot of the error and post the image here.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: lordoflinks am 11. Jul 2016, 10:35
I tried to but the forum does not allow png or jpg files to be uploaded.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: FG15 am 11. Jul 2016, 12:00
You can upload it, using a free upload site, and post the link here.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: lordoflinks am 11. Jul 2016, 13:04
Does this work?
https://postimg.org/image/m8vi11xon/
I've never uploaded a image before.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: lordoflinks am 16. Jul 2016, 05:13
I've figured out my problem, I had to manually rename the Chronicles submod from ***.big to ***.bi
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: DrHouse93 am 24. Jul 2016, 15:04
Since Thorin will be the Ringhero of the Ered Luin in the upcoming patch 4.4, here's a bunch of Mad Thorin's sounds to properly differentiate standard Thorin from his greedy counterpart (furthermore enhanced by the evil power of the Ring), ripped by me

Hope you like it :)
https://www.dropbox.com/s/bki5dpo56zi9epg/MadThorinSoundset.rar?dl=0
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: tima am 26. Jul 2016, 15:30
Here is my problem,
when i try to launch the game on my laptop the splash screen loads fine and it plays the edian video fine, than it load on the 4.3.2 image screen for a brief minute and then it will just launch the main menu for a split second and crash to desktop and it dose not give me a crash report. windows just gives me the generic

"the battle for middle earth II has stopped working"
"a problem caused the program to stop working correctly. windows will close the program and notify you if a solution is available."

Also this may help,
i have the legitimate physical copy of the game and the rotwok expansion
rotwok will load all the way to the main menu but will crash as soon as i click any of the buttons except for the Agmar campaign which then prompts me with the difficulty setting and and then will start playing the agmar video but still crash as soon as the videos are over.
BFME II gets stuck on the splash screen.

now the game works on my desktop even though i installed it the same exact way.
both my computers are running windows 10
they both have a GTX 900 series graphics cards.

Please help

Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: tima am 29. Jul 2016, 03:17
Here is my problem,
when i try to launch the game on my laptop the splash screen loads fine and it plays the edian video fine, than it load on the 4.3.2 image screen for a brief minute and then it will just launch the main menu for a split second and crash to desktop and it dose not give me a crash report. windows just gives me the generic

"the battle for middle earth II has stopped working"
"a problem caused the program to stop working correctly. windows will close the program and notify you if a solution is available."

Also this may help,
i have the legitimate physical copy of the game and the rotwok expansion
rotwok will load all the way to the main menu but will crash as soon as i click any of the buttons except for the Agmar campaign which then prompts me with the difficulty setting and and then will start playing the agmar video but still crash as soon as the videos are over.
BFME II gets stuck on the splash screen.

now the game works on my desktop even though i installed it the same exact way.
both my computers are running windows 10
they both have a GTX 900 series graphics cards.

Please help

Nevermind i found the fix, it was the windows 10 graphics adapter thing.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 31. Jul 2016, 12:20
Great to hear!
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: DrHouse93 am 31. Jul 2016, 21:47
Edain Team, to whom may I send various sounds I've cut? Those include Mad Thorin and Gondor's and Rohan's horns
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Walküre am 31. Jul 2016, 21:58
You can send them to FG15. He's the one who takes care of the English sounds  :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: DrHouse93 am 1. Aug 2016, 09:20
Thank you, Walk ;)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Crimson King am 21. Aug 2016, 21:58
Hi, I had to reinstall the game after formatting my laptop but now I'm having a problem with the voices in the game, all of them are in german. This problem seems to be affecting other people as well.

Hi all :).

First of all thanks for this great mod.

I have just installed Edain Launcher and the latest Edain version. I have BfmeII 1.06 and ROTWK 2.01.

The mod starts with no issues and I enter a skirmish game. All the text and voices of units are in english, except for hero voices who still speak in german.

I have tried switching the mod from English to German and back to English.

I tried deleting german patches in ROTWK and deleting __edain_german.big file, but still no luck.

Anyone have an idea?

I am missing english.ini file.
I try to update the mod through the launcher and it states i am missing English.ini file, widescreen file and one other. It then looks for updates and downloads the English.ini file and the two others ( about 700mb download).

I then again check through launcher if I need an update and same things happens again (700mb download).

Any ideas?

Hi guys,

when I use the updater and ends appears this message:

_english_ini.big not found. The update might not work correctly in this case

I'm playing the version 4.4 of the mod,  the launcher is in english but the text in the game and the voices run in german, what I can do?


Sorry for my bad english and ty for help me :(

In my case, this is what it looks like


Any suggestions on how to fix this or why the files are not being downloaded properly?


Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 22. Aug 2016, 00:07
You provably installed an old version before 4.0. Download the 4.3 setup, install it and update then. It should work fine afterwards.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Crimson King am 23. Aug 2016, 17:33
You provably installed an old version before 4.0. Download the 4.3 setup, install it and update then. It should work fine afterwards.

Yup, that works, many thanks!
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Edhelharn am 25. Aug 2016, 14:12
Hi Edain team,

I would just like to say thank you for creating this wonderful mod for everyone to enjoy. But I have encountered a problem since updating from 4.4 to 4.4.1. The game starts to load however a crash occurs a few seconds later. I can still play the vanilla game.

Invalid Sound 'ElbenfurstVoiceAttack'

Error parsing field 'VoiceAttack' in block 'Object' in file
'data\ini\object\createahero\CreateAHeroAudio.inc', line 379.

Error parsing field 'VoiceAttack' in block 'Object' in file
'data\ini\object\createahero\CreateAHeroAudio.inc', line 379.

Error parsing field 'VoiceAttack' in block 'Object' in file
'data\ini\object\createahero\CreateAHeroAudio.inc', line 379.

Error parsing INI block'             VoiceAttack' in file
'data\ini\object\createahero\createahero.ini'.
7 addresses
(unknown)(0): game.dat+240382 Debug::PostStaticInit+3390
(unknown)(0): game.dat+2347216 IntRange::IntRange+93886
(unknown)(0): game.dat+2377423 IntRange::IntRange+124093
(unknown)(0): game.dat+6542103 Xfer::~Xfer+118430
(unknown)(0): kernel32.dll+323356 BaseThreadInitThunk+18
(unknown)(0): ntdll.dll+407112 RtInitializeExceptionCha in+239
(unknown)(0): ntdll.dll+407067 RtInitializeExceptionCha in+194

Because of the severity of this error the game will now exit.

Any help will be greatly appreciated.

Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 25. Aug 2016, 16:02
Try updating again to see of any of your mod files are damaged.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Edhelharn am 26. Aug 2016, 16:44
Hi Turin,

Thanks for the quick reply. I tried what you said on both the servers and it says no updates are available.

Edit: I am still receiving the same error because when I searched for updates it said I have the latest version. What else can I try?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: jhallam1995 am 29. Sep 2016, 13:57
Hello!
Okay, I have tried to install Edain twice now and it all went totally fine but it still won't work.

Here's what I did:

I installed both BFME 2 and RotWK and updated both (1.06 BFME2 / 2.01 RotWK).

Then downloaded the Edain mod and it's launcher. Installed the mod, then launcher.
All worked fine so far.

Then I updated the mod and launcher through the launcher which again worked fine.

So then I go to press play and the exact same thing happened this time as it did last time. NOTHING. Absolutely nothing. The launcher disappears and a rotating loading sign floats near my mouse for like 5 seconds and then disappears. No game, no nothing. It's as if I never pressed play.

Any ideas what is wrong?
Thanks for any help offered!
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 29. Sep 2016, 16:03
Did you press the "Non starting-Fix" button in the launcher?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: jhallam1995 am 29. Sep 2016, 16:08
Thanks for the quick reply. Yeah I did. No change. I've uninstalled Edain and RotWK and am going to start again. I'll give an overview of how that goes in a sec.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 29. Sep 2016, 16:15
Do you have a intel HD graphic? If yes, check this threads out:

https://modding-union.com/index.php/topic,33654.0.html
https://modding-union.com/index.php/topic,31635.0.html

Also in the german forum there is someone who has found an intel triver to fix this problem with win 10:
Zitat
Ich habe es mittlerweile geschafft, Edain auf Win 10 mit einer Intel HD 5000 (Surface Pro 3) zu starten.

Verwendeter Treiber ist
10.18.10.3907
(Achtung bei Win Updates, da wird er öfters mal ersetzt!)

(gefunden in diesem Support-Thread)
https://communities.intel.com/thread/99097?start=15&tstart=0

Vielleicht hilft diese Information dem ein oder anderen...
Follow the therad.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: jhallam1995 am 29. Sep 2016, 16:19
I'm afraid I'm not very tech savvy. I think that I have Nvidia if that is what you're asking about, so not Intel. Sorry if I'm stupidly wrong.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Ealendril der Dunkle am 29. Sep 2016, 16:31
I just mean your graphic card. :) What kind of is it?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: jhallam1995 am 29. Sep 2016, 17:41
Don't worry! I figured out what I was doing wrong. Basically the 2.01 patch for RotWK was one the EA link or something to that effect. That one wouldn't match with the RotWK retail game disc. Kind of weird, but it worked so hey-ho.

But, I encountered another problem. It might just be the map I was playing, Dol Amroth or something along those lines. Then whilst loading the skirmish it crashed.

The error script mentioned this:

Direct3D error 0x0x8007000e (E_OUTOFMEMORY)
16 addresses:
(unknown)(0): game.data+239838 (unknown) etc.
then just game has exited bye.

I'm hoping that it isn't a lasting issue and was just a fluke but thought I'd ask around.

Kind of weird, but the first problem was soon fixed so I have faith we can figure out this one. It may have been explained before which I'm sorry for if that is the case.
Any help would be awesome.



Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Hamanathnath am 16. Okt 2016, 02:35
Not entirely sure how, but my launcher isn't allowing me to switch back to Rotwk 2.01.  I get this "Oops, something went wrong..." message telling me to report here with my event log.  However, it also won't allow me to add my event log here because it apparently not a .txt document.

Not sure what to do, so any help would be appreciated :)
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Turin Turumbar am 16. Okt 2016, 11:18
Just rename the File to .txt in the End and it should work.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Hamanathnath am 16. Okt 2016, 19:36
Okay, thank you.  Here it is.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: DrHouse93 am 16. Okt 2016, 21:22
A friend of mine got a weird problem. Basically, he installed the game and the mod successfully, and we also managed to play some games. However, the next day, he started having the 3.30 minutes autodefeat (he has the original game) and he couldn't fix it even by reinstalling it multiple times.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Mateiyu am 9. Jan 2017, 10:26
Hi all !

I've been playing Edain 4.4.1 since July (late comer, I know), and apart from a few CTDs now and then, it was running smoothly.

But recently, I have two major separate issues :
 - whenever I play with the Lothlorien faction, I can play for several minutes (around 40 give or take ?), and then the game crashes ("BFME has stopped working, etc...") ; this only happens with Lothlorien ;
 - when I try to play with Rohan or Arnor on a map I already played on before (hours or months before), I get an instant victory after a few seconds of game (not enough to actually do anything in-game) ;

On the other hand, I have no issues with the Gondor faction whatsoever (as of yet anyways). I haven't tried Mordor, Isengard or Angmar in a few weeks (too much work).

Anybody know what I should do ? Thanks !
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Project Gnome am 29. Jan 2017, 04:46
My younger brother and I are having an error where the game constantly loses synchronization during multiplayer in Edain 4.4.1. I have even copied the files over from my computer to his so that everything in our folders are identical yet the error persists.

We have spent over 12 hours reinstalling and troubleshooting the issue and cannot find the root of the problem. This does not happen in normal RotWK so it has to be related to the mod. It is rather aggravating because we really want to play the mod but we get a sync error 5 minutes in and goes back to the menu.
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: ed am 23. Mär 2017, 05:09
hello everyone!!  i modified a map from rotwk,  i add some reinforcements,  i put more money,  and in Edain mod the game stars well  in the skirmish, but after 7 or 10  seconds , everybody dies and says defeated,

i changed the start point in to team PlyrCivilian/teamPlyrCivilian and FestungPlotFlag as well,   help please !!!

 
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: lotr1997 am 27. Apr 2017, 21:21
Sadly I cannot launch the game. When I click on the shortcut or the .exe it just does not open. This is really annoying because I cant play this great mod :( Hilf mir bitte  :(
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: Amonrath am 17. Aug 2017, 21:54
Hello guys. I'm new to this community. I just want to know if I can plain Edain Mod without the DVD. My DVD no longer works and the Fix Non Starting Games didn't help. Is there anything I can do?
Titel: Re: [en] Support Edain Demo 4.0
Beitrag von: FG15 am 9. Okt 2019, 18:01
This post has been moved to https://modding-union.com/index.php/topic,35816.0.html (https://modding-union.com/index.php/topic,35816.0.html).

Dieser Beitrag wurde nach Start-Problem (https://modding-union.com/index.php/topic,35816.0.html) verschoben.